Managing Contacts

The following article is outdated. You can view the updated guides here.

Managing your contacts is super simple with iMazing. You can export them from your device to your computer into your prefered contact manager application or to the standard vCard file format (.vcf) or even to .csv for manipulation in a spreadsheet. You can also import contacts from your contact manager application or from vCard files.

 

 

Exporting Contacts

First you need to get the contacts off of your iPhone and onto your PC. Launch iMazing and plug in your Apple device. Select Contacts in the left of iMazing and select the contacts that you wish to transfer. You then have 3 main options...

 

 

Export to vCard

By selecting the "Export to vCard" option in the bottom toolbar you will create .vcf files which are the standard contact format. When you click this option you will be asked whether you wish to export all of your Contacts, or only the selected Contacts. Make your selection and confirm the location that you wish for the contact files to be created.

Once you have your vCard you can either import it into your contact manager application on your computer (drag/drop or simply opening the file suffices for most contact managers), or you can use iMazing to import the contacts into another Apple device.

Please note that by default iMazing will create a single vCard file containing your selection of multiple contacts. Some contact manager applications (e.g. MS Outlook) do not support single vCard files containing multiple contacts. In this instance you need to open the iMazing Preferences (in the File menu) and select the "Export contacts as single VCards" check box, on the "Other Data" tab.

 

 

Open in Contacts

Alternatively you can simply open your contacts directly in your contact manager. To do this, select your contacts that you wish to transfer, right click on the selection (or <command> click or two-finger-tap on Mac OS X), and select "Open With >", and select from the compatible applications.

 

 

Export to CSV

Additionally you can export your contacts as a CSV file. This is useful in spreadsheet applications, allowing you to sort and manipulate the data as you wish. Depending upon which spreadsheet application you prefer you may need to change the delimiter option in the iMazing Preferences on the "Other Data" tab.

 

 

Importing Contacts to your Device

Once you have your contacts stored on your computer, you can use iMazing again to transfer them back to your device, or to another Apple device. To do this simply connect your device, select Contacts in the left, and click on either the "Import from VCard", or "Import from Contacts" options in the bottom toolbar. If you select the "Import from VCard" option your will be asked to locate the vCard file and confirm. If you select "Import from Contacts" you will be prompted to select which contacts you wish to transfer from your contact manager application.

 

 

Deleting Contacts

Deleting contacts from your device is easy. To do so just connect your device, select Contacts from the left of iMazing, select the contact(s) that you wish to remove from your device, and click on the Delete option in the bottom toolbar. Alternatively you can also select your contact(s), right click on the selection (or <command> click or two-finger-tap on Mac OS X), and select Delete Contact from the dropdown menu.

Have more questions? Submit a request

Comments

Powered by Zendesk